Eduroam Wireless Network

Incident Report for AppState Status Page

Resolved

This incident has been resolved.
Posted Jun 09, 2026 - 10:02 EDT

Monitoring

A fix has been implemented and we are monitoring the results. Please contact our help desk at 828-262-6266 should you experience any ongoing Eduroam issues.
Posted Jun 08, 2026 - 16:30 EDT

Investigating

The Eduroam wireless network is currently unavailable in campus buildings, impacting wireless connectivity for campus users with Eduroam enabled devices. We are actively involved with the vendor to identify the cause and restore service as quickly as possible.
Posted Jun 08, 2026 - 08:01 EDT
This incident affected: Networking (Wireless).